android - android 2.2到1.6?

原文 标签 android android-version

我一直在开发一个Android应用程序。我选择了2.2作为版本。我没有使用任何特定于2.2或更高版本的高级功能。我希望我的应用程序能与1.6及以上版本一起工作。我该怎么办?
谢谢。

最佳答案

补充预览答案。
android使代码尽可能自动向上兼容(并不总是如此)。
但是降低了应用程序的api级别。可以是一个从简单到噩梦的任务来执行,一切都取决于你的代码是否使用了很多特定的2.2…
这意味着在项目中更改api级别或android.jar可能远远不够。
祝你好运

相关文章:

android - 为什么Android版本代码和版本名称会继续回到1和1.0?

android - Android应用程序在不同版本的Android中的兼容性

android - Android应用程序的付费和免费版本

android - 通过Android App注册时Mysql Query中的错误

android - 语音识别Android应用

android - 将Android SDK更新到21版并将Android平台工具更新到16版后的模拟器轮换问题

android - 如何合并分支并忽略由flutter生成的二进制文件中的冲突?

java - 如何在Android Studio中将图像上传到图像滑块?

java - 在EditText中打开DatePicker单击不会在第一次单击时显示