java - Maven构建-Eclipse构建中的错误

标签 java eclipse maven

如何在Eclipse中构建maven WebApplication

我在下面尝试过
项目->右键单击->运行方式-> Maven构建

这是给GoalProfile的窗口

我在下面遇到错误,

lifecycle phase "Snapshot-1.0". You must specify a valid lifecycle phase or a goal in the format <plugin-prefix>:<goal> or <plugin-group-id>:<plugin-artifact-id>[:<plugin-version>]:<goal>. 


我应该以GoalProfile给出什么?以及它将如何影响pom.xml?

谢谢。

最佳答案

以“全新安装”或“安装”为目标。除非您的POM文件定义了配置文件,否则您无需提供配置文件。

关于java - Maven构建-Eclipse构建中的错误,我们在Stack Overflow上找到一个类似的问题: https://stackoverflow.com/questions/8878890/

相关文章:

java - Maven多模块的Spring Hibernate配置

java - com.sleepycat.je.DatabaseNotFoundException 找不到数据库

eclipse - 在 Eclipse 中,当 Assert.assertEquals 失败时如何查看输入?

eclipse - 通过Eclipse插件以编程方式更改菜单项

android - Eclipse for Android SDK 的正确版本

maven - 使用 Java 11 运行 Spring Boot 应用程序时出现 java.lang.StackOverflowError

java - 尝试将本地依赖项添加到Heroku Java应用程序时无法接收到依赖项错误

java - Java 和 Python 之间的套接字连接 - struct.unpack 错误

java - jButton HashMap计数请点击

java - 如何将图像保存到 zip 文件中