java - Google App Engine和Java版本

原文 标签 java google-app-engine

嗨,我安装了Java 7,并在ubuntu.com上使用了Eclipse Juno。在Google App Engine中。我经历了一些查询,但无法解决。我是ubuntu的新手。任何人都可以帮助解决该错误。请帮助我。

我现在再次尝试使用jre系统库java-6-openjdk-i386和appengine 1.7.0 sdk
但仍然出现相同的错误500内部服务器错误不支持的major.minor版本51.0。
请为我运行第一个项目提供一些帮助

最佳答案

看来Java 7支持已于上个月到达。这已经清除了您遇到的问题。

“在2013年2月发布的App Engine 1.7.5中,Java运行时添加了对Java 7的可选支持,作为一项实验功能。”

“在将来的版本中,将删除对Java 6的支持,因此,最好在新的Java 7运行时中尝试运行现有的基于Java 6的应用程序,而仍然是可选的。”

https://developers.google.com/appengine/docs/java/java7

关于java - Google App Engine和Java版本,我们在Stack Overflow上找到一个类似的问题: https://stackoverflow.com/questions/11881717/

相关文章:

java - Spring RabbitMQ 监听器返回一个以逗号分隔的 ASCII 小数的字符串

java - 第35分钟每小时运行一次的cron cron

python - 如何在 Google App Engine 的网络应用程序中检测在线用户

java - gwt 的 openid 消费者

java - Google App Engine - Go vs. Python 推荐?

java - 使用 Java7 在 OSX 上启用 Swing 菜单

java - 新手努力从arraylist中删除对象

java - 如何使用 java 从谷歌应用引擎中的模型中删除字段?

java - 谷歌应用引擎 : Java or Python

java - 如何用 Java 8 编写 instanceof?