java - unitils-orm-hibernate 不适用于 Hibernate 5

原文 标签 java hibernate orm unitils

我正在使用 unitils 进行 hibernate orm 测试。我采用了 hibernate 版本 5.0.10-Final 和最新的 unitils 版本 3.4.3。
我总是收到以下错误:“org.unitils.core.UnitilsException:加载核心模块 hibernate 期间发生异常,模块类名为 org.unitils.orm.hibernate.HibernateModule -> 由:org.unitils 引起。 core.UnitilsException:无法加载名为 org.hibernate.cfg.AnnotationConfiguration 的类

当我查看代码时,我可以看到(在旧版本的 Hibernate 4 中)AnnotationConfiguration 已被弃用,并将在 Hibernate 5 中被替换。显然,unitils 仍然希望该类作为属性“HibernateModule.configuration.implClassName”存在仍然指向这个类。

我需要其他配置吗?还是其他版本?

最佳答案

您只需要在下一行添加到 unitils 配置:

HibernateModule.configuration.implClassName=org.hibernate.cfg.Configuration

关于java - unitils-orm-hibernate 不适用于 Hibernate 5,我们在Stack Overflow上找到一个类似的问题: https://stackoverflow.com/questions/40280659/

相关文章:

java - ejp:如何保存修改后的对象?

php - PHP 中的 ORM 和 Active Record 模式?

java - 如何通过套接字传递 FTP 服务器的目录结构并使用 JTree 在客户端的 GUI 中显示它

java - 运行 Flexunit 测试时出现 BlazeDS 错误 : Detected duplicate HTTP-based FlexSessions

java - 输入类型 ="date" thymeleaf

java - 在 hibernate 中将哈希函数委托(delegate)给未初始化的委托(delegate)会导致更改 hashCode

python - 为 Django 查询强制 INNER JOIN

java - 获取实时Log4J消息

java - 使用Java修改MongoDB数组

java - 在Spring Boot中使用hibernate-types-52时如何禁用Hypersistence横幅?