c - Linux 中 FreeBSD 的 be64enc 和其他 dec/enc 等效函数?

标签 c endianness

Linux 的 C 库中是否存在函数 *dec/*enc(例如 be64enc)?它们确实存在于 FreeBSD 中,但在 Linux 中我只能找到 hto*/*toh 函数,恐怕它们的功能不完全相同。

提前致谢。

最佳答案

他们没有:

$ uname
Linux
$ man be64enc
No manual entry for be64enc

Google 快速搜索证实了这一点,没有 Linux 条目。

我找不到这些函数应该做什么。这是关于此主题的唯一手册页 (BSD),但它并不是特别有用:

BYTEORDER(9)              BSD Kernel Developer's Manual              BYTEORDER(9)

NAME
     bswap16, bswap32, bswap64, be16toh, be32toh, be64toh, htobe16, htobe32, htobe64, htole16,
     htole32, htole64, le16toh, le32toh, le64toh, be16enc, be16dec, be32enc, be32dec, be64enc,
     be64dec, le16enc, le16dec, le32enc, le32dec, le64enc, le64dec -- byte order operations

SYNOPSIS
     #include <sys/endian.h>

     uint16_t
     bswap16(uint16_t int16);

     uint32_t
     bswap32(uint32_t int32);

     uint64_t
     bswap64(uint64_t int64);

     uint16_t
     be16toh(uint16_t big16);

     uint32_t
     be32toh(uint32_t big32);

     uint64_t
     be64toh(uint64_t big64);

     uint16_t
     htobe16(uint16_t host16);

     uint32_t
     htobe32(uint32_t host32);

     uint64_t
     htobe64(uint64_t host64);

     uint16_t
     htole16(uint16_t host16);

     uint32_t
     htole32(uint32_t host32);

     uint64_t
     htole64(uint64_t host64);

     uint16_t
     le16toh(uint16_t little16);

     uint32_t
     le32toh(uint32_t little32);

     uint64_t
     le64toh(uint64_t little64);

     uint16_t
     be16dec(const void *);

     uint32_t
     be32dec(const void *);

     uint64_t
     be64dec(const void *);

     uint16_t
     le16dec(const void *);

     uint32_t
     le32dec(const void *);

     uint64_t
     le64dec(const void *);

     void
     be16enc(void *, uint16_t);

     void
     be32enc(void *, uint32_t);

     void
     be64enc(void *, uint64_t);

     void
     le16enc(void *, uint16_t);

     void
     le32enc(void *, uint32_t);

     void
     le64enc(void *, uint64_t);

DESCRIPTION
     The bswap16(), bswap32(), and bswap64() functions return a byte order swapped integer.  On
     big endian systems, the number is converted to little endian byte order.  On little endian
     systems, the number is converted to big endian byte order.

     The be16toh(), be32toh(), and be64toh() functions return a big endian byte ordered integer
     converted to the system's native byte order.  The return value will be the same as the argu-
     ment on big endian systems.

     The le16toh(), le32toh(), and le64toh() functions return a little endian byte ordered inte-
     ger converted to the system's native byte order.  The return value will be the same as the
     argument on little endian systems.

     The htobe16(), htobe32(), and htobe64() functions return a integer in the system's native
     byte order converted to big endian byte order.  The return value will be the same as the
     argument on big endian systems.

     The htole16(), htole32(), and htole64() functions return a integer in the system's native
     byte order converted to little endian byte order.  The return value will be the same as the
     argument on little endian systems.

     The be16enc(), be16dec(), be32enc(), be32dec(), be64enc(), be64dec(), le16enc(), le16dec(),
     le32enc(), le32dec(), le64enc(), and le64dec() functions encode and decode integers to/from
     byte strings on any alignment in big/little endian format.

SEE ALSO
     byteorder(3)

HISTORY
     The hto*() and toh*() functions first appeared in FreeBSD 5.0, and were originally developed
     by the NetBSD project.

     The encode/decode functions first appeared in FreeBSD 5.1.

BSD                   April 29, 2002                      BSD
<小时/>

如果您具体说明您面临的问题以及您尝试过的操作,也许我们可以更好地帮助您。提出一个新问题,详细说明您的问题、您尝试过的操作以及以前可能对您有效的操作。

关于c - Linux 中 FreeBSD 的 be64enc 和其他 dec/enc 等效函数?,我们在Stack Overflow上找到一个类似的问题: https://stackoverflow.com/questions/26346716/

相关文章:

c++ - 调用 socket::connect、socket::bind、socket::listen 之前不使用 getaddrinfo( ) 函数

c - 将数组结构传递给函数

c - fcntl() 的返回值带有 F_GETFD 标志?

c - C中使用指针数组对字符串进行排序

c++ - 将浮点值从大端转换为小端

python - ctypes bigendianstruct Littlendianstruct 对单字节返回不同的结果

PHP - 将小端十六进制转换为大端十六进制

c - C 中的静态变量(在 main 中声明)。混淆

c - alloca 是完全可替换的吗?

C - 如何将 int 转换为 uint8_t?