ios - Swift 3.0 或 Swift 2.3 最低系统版本要求,是否已部署在 iOS 7 中

原文 标签 ios swift ios7 osx-elcapitan xcode8

这个问题在这里已经有了答案:





Swift 3 iOS compatibility

(2 个回答)


5年前关闭。




Swift 3.0 即将推出 Xcode 8,使用 Swift 3.0 所需的最低 iOS/OS X 系统版本是多少?那 swift 3.0 支持 iOS 7 吗?

最佳答案

运行与 Swift 3 兼容的 Xcode 8 的最低 OS X 是 OS X 10.11.4 (OS X EL Capitan)

enter image description here

而且我认为 Swift 3 不支持 iOS 7

由于您在 Xcode 8 中的最低目标是 iOS 8.0

enter image description here

根据 App Store 对 iOS 8 (11%) 和 iOS 9 (84%) 的支持测量,我认为你停止对 iOS 7 的支持更好。 iOS 10 即将推出。

enter image description here

关于ios - Swift 3.0 或 Swift 2.3 最低系统版本要求,是否已部署在 iOS 7 中,我们在Stack Overflow上找到一个类似的问题: https://stackoverflow.com/questions/38092144/

相关文章:

ios - iOS 7 中的静默推送通知是否有速率限制?

ios - 无法推断通用参数类型“T”

ios - iOS-NavigationBar隐藏/显示

ios - 如何使用SWIFT3解析此JSON

ios - 电话的NSURL始终为零

ios - 为什么我不能在Swift中使用从一个UIViewController传递到另一个UIViewController的数据来设置标签(在控制台中打印数据)?

ios7 - 带有自定义后退按钮的滑动手势会卡住根 View Controller

ios - 如何在iOS 7中隐藏状态栏?

ios - 制作自定义相机,我的应用程序委托(delegate)中出现 “Thread 1: signal SIGBRT”错误

ios - 尝试与IMessage和Social Media Swift共享数据时发生 fatal error