加载JNI共享库失败(JDK)

问题:当我试图打开Eclipse时,会弹出一个提示写着: Failed to load the JNI shared library “C:/JDK/bin/client/jvm.dll”`. 然后,Eclipse会强制关闭。 我做了以下几点: ·我检查那个路径有没有存在什么,真的有存在。 ·我的Eclipse和Java SE Development Kit都是64位的。我检查我的系统,它能处理64位。 ·我也在Google和Stack Overflow搜索解决方法,我找到唯一的方法是下载一个32位版本的JDK和Eclipse。 下载32位版本是我没办法下的办法。但还有其他的解决方法吗?

回答: 你需要一个三件套: ·64位的操作系统 ·64位的Java ·64位的Eclipse

网站遵循 CC BY-SA 4.0 协议,转载或引用请注明出处。

标签 IT工具网 java


相关文章:

java - Map<Key,Value>基于Value值排序

为什么打印“B”会明显的比打印“#”慢

一些JavaScript的编码习惯和奇怪写法

java - 将数据模型映射到领域模型的简便方法

java - 使用for循环遍历2D数组

java - MySql驱动程序未在Java中加载

Node.js适用于哪些场景

使用jquery将表单数据转换为javascript对象

java - java.lang.nullpointerexception?

java - 为什么<?扩展Number>不适用于Integer?