ios - 将 xcode 升级到 10.2 版后面临 AFNetworking 错误

标签 ios objective-c xcode afnetworking

今天,我将我的 xcode 版本从 10.1 升级到了 10.2 版本。在 xcode 10.1 中,我的项目运行良好,但在将其升级到 10.2 后,我面临以下错误。我正在使用 pod 将库集成到我的项目中。 pod 版本如下:

pod 'AFNetworking', 3.1.0
pod 'AFOAuth2Manager', '3.0.0'
pod 'AFNetworking+streaming', '1.0.2'

我检查了 cocoapods,这两个库都是最新版本。




最佳答案

要遵循的步骤

  • 移除工作空间
  • 删除 Pod 文件夹
  • 删除 Podlock 文件
  • root上的终端命令

    sudo gem install cocoapods



  • pod install

  • 现在运行工作区。
  • 关于ios - 将 xcode 升级到 10.2 版后面临 AFNetworking 错误,我们在Stack Overflow上找到一个类似的问题: https://stackoverflow.com/questions/57325598/

    相关文章:

    iphone - XCode的尺寸+启动屏幕的名称和iPhone 4图标

    ios - AFOAuth2Client 和刷新 token

    ios - Swift 不能使用函数指针吗?

    ios - 无法将 channel 保存到PFInstallation(iOS)

    iphone - CollectionView iOS 6 问题

    ios - 具有componentsSeparatedByString()的断点

    objective-c - 未找到符号。收集2 : Id returned 1 exit status

    ios - 选择表情符号时键盘顶部出现随机蓝色

    ios - 更改右侧图标图像 UITextField

    ios - 使用 AutoLayout 在 UIScrollView 中居中固定 UIView