java - eclipse(3.5 和 3.6)在 ubuntu 中崩溃

标签 java eclipse ubuntu-10.04

我在 ubuntu 10.04 (x86) 中遇到了 eclipse 的问题。我通过下载 zip 文件而不是从源代码安装了 eclipse。一切都很好,直到我决定尝试 eclipse 3.6,我下载的 eclipse 3.6 就像我下载 3.5 一样...

好吧,我将 3.6 保存在 3.5 以外的另一个目录中,启动它并打开了一个我用 3.5 创建的工作区。在使用 3.6 工作之后,我注意到以下问题:

有时,当我输入诸如 CLASSNAME 之类的内容时。或变量。 (即弹出代码完成对话框时),eclipse 崩溃,当我尝试

  • 关闭代码完成窗口(例如按 ESC)
  • 从代码完成窗口中选择某事

或其他任何东西。这个问题在任何时候都不会在 3.5 内发生。好吧 - 切换回旧的 3.5 并没有解决问题。崩溃现在也发生在这个版本中:(

所以我尝试:

  • 删除/home/USER/.eclipse 目录
  • 从源代码重新安装 java
  • 创建一个全新的工作区
  • 尝试了来自源 (3.5) 的 eclipse 版本

没有任何帮助:(

我没有主意...我该如何解决这个问题?

最佳答案

看起来像bug 308731 ,这是 XulRunner 相关的。

I confirm that the Steffen's solution works for me and it is necessary to set the property "-Dorg.eclipse.swt.browser.XULRunnerPath".

I set:

-vmargs
-Dorg.eclipse.swt.browser.XULRunnerPath=/usr/bin/xulrunner-1.9.2

in my eclipse.ini

https://bugs.eclipse.org/bugs/attachment.cgi?id=160189
(在内容辅助选择中按 Enter 时崩溃)

关于java - eclipse(3.5 和 3.6)在 ubuntu 中崩溃,我们在Stack Overflow上找到一个类似的问题: https://stackoverflow.com/questions/3190000/

相关文章:

java - 关于 Selenium : find element by its child link text 的问题

Java - 错误消息显示不正确

java - 无法使用 Openshift 客户端工具

java - 远程启动Android SDK

linux -/usr/src 目录是否与 Linux 内核的引导有任何关系?如果是,如何?

java - JavaFX中的CheckBox问题

java - 无法使用 GAE 运行 Web 项目

java - 关于对象池的问题

java - 用Java导入类

java - Eclipse - 开放声明/实现/返回类型的更改顺序