node.js - 无法安装 ionic 框架

标签 node.js ionic-framework

我正在尝试安装 ionic 框架,但运行“npm install -g ionic”时不断收到错误。

这就是错误:

npm ERR! Error: No compatible version found: colors@'^0.6.2' npm ERR! Valid install targets: npm ERR! ["0.3.0","0.5.0","0.5.1","0.6.0","0.6.0-1","0.6.1","0.6.2"] npm ERR!
at installTargetsError (/home/myname/local/lib/node_modules/npm/lib/cache.js:685:10) npm ERR! at /home/myname/local/lib/node_modules/npm/lib/cache.js:607:10 npm ERR! at saved (/home/myname/local/lib/node_modules/npm/node_modules/npm-registry-client/lib/get.js:138:7) npm ERR! at Object.oncomplete (fs.js:107:15) npm ERR! If you need help, you may report this log at: npm ERR!
http://github.com/isaacs/npm/issues npm ERR! or email it to: npm ERR!

我已经更新了 Node 并清除了缓存。

有什么想法吗?

最佳答案

尝试这样

sudo npm install -g cordova ionic

同时使用 Cordova 和 ionic。确保添加到 sudo

关于node.js - 无法安装 ionic 框架,我们在Stack Overflow上找到一个类似的问题: https://stackoverflow.com/questions/23185847/

相关文章:

typescript - ionic : How do I hide an element on load

javascript - Storage get() 在 ionic 2 中永远不会返回值

css - 与 Ionic app + Bootstrap 中的样式混淆

html - 如何模拟输入时出现的浮点值

javascript - NodeJS、Windows、wmic 标准输入

javascript - Meteor 方法调用 - 等待方法完成

node.js - Nodejs Exec不执行

sql - 如何使用 SQL 锁定登录尝试

javascript - 在任何事情之前删除数据库

android - 错误: Error: Failed to find 'ANDROID_HOME' environment variable