node.js - 如何安装以前精确版本的 NPM 包?

标签 node.js npm

我使用 nvm 下载 node v0.4.10 并安装 npm 以使用该版本的 node。

我正在尝试使用

安装 express
npm install express -g

我收到一个错误,表示需要 Node 版本 >= 0.5.0。

嗯,这很奇怪,因为我按照 node+express+mongodb 教程的说明 here使用 Node v0.4.10,所以我假设 express 对 Node v0.4.10 可用/可用。如果我的假设是正确的,我如何告诉 npm 获取适用于我的设置的版本?

最佳答案

如果您必须安装旧版本的软件包,只需指定它

npm install <package>@<version>

例如:npm install express@3.0.0

您还可以将 --save 标志添加到该命令以将其添加到您的 package.json 依赖项中,或者 --save --save-exact 标志如果您想要在 package.json 依赖项中指定的确切版本。

install 命令记录在这里:https://docs.npmjs.com/cli/install

如果您不确定可用的软件包版本,您可以使用:

npm view <package> versions

并且 npm view 也可以用于查看包的其他内容。 https://docs.npmjs.com/cli/view

关于node.js - 如何安装以前精确版本的 NPM 包?,我们在Stack Overflow上找到一个类似的问题: https://stackoverflow.com/questions/15890958/

相关文章:

node.js - 使用 mongoose 按日期发出排序

javascript - 如何确保 mocha 测试中的 'this' 可以访问类属性

node.js - 仅从搜索中返回 _source

javascript - Sequelize 无法创建表,但是当我在 MySQL CLI 中运行它时它可以工作

angular - ts 找不到模块 '@angular/platform-browser' ;

npm - 强制 npm 更新依赖

javascript - 如何在Javascript中以正确的顺序输入数据?

node.js - putBotAlias 在 AWS LexModelBuildingService node.js 中不起作用

reactjs - 找不到雪包 "abstracts/variables"。你安装了吗?运行 npm start 时出现此错误

javascript - Electron 生成器: “Error occurred in the main process - Callback is not a function”